BeA

Aus Lawsuit - Wiki
Wechseln zu: Navigation, Suche
Kompatibilität mit openSUSE openSUSE-Themen Weiterführende Artikel Suse.png



Einführung[Bearbeiten]

Ab dem 01.01.2018 ist das besondere elektronische Anwaltspostfach für Rechtsanwälte in Deutschland insofern verbindlich, als zu diesem Zeitpunkt die sog. „passive Nutzungspflicht“ hinsichtlich des Anwaltspostfachs eintritt. Nach § 31a VI BRAO n.F. ist der Inhaber des beA verpflichtet, die für dessen Nutzung erforderlichen technischen Einrichtungen vorzuhalten sowie Zustellungen und den Zugang von Mitteilungen über das besondere elektronische Anwaltspostfach zur Kenntnis zu nehmen.



Hardware[Bearbeiten]

Die günstigste Hardware aus der Liste der unterstützten Kartenlesegeräte sind momentan Einzelkartenlesegeräte, deren Installation deshalb hier beschrieben wird. Für andere Hardware nutzen Sie bitte die entsprechenden Downloadseiten des jeweiligen Herstellers.

Das Ghostscript, bzw. der Linux-Treiber für Cherry-Lesegeräte findet sich unter

(bitte nicht die CT-API herunterladen, diese wird für Gesundheitskarten gebraucht und blockiert die hier benötigten Einstellungen),

für Cardman-Geräte findet er sich unter

und für Reiner-SCT-Geräte unter


Installation[Bearbeiten]

Installieren Sie die notwendigen Programme

sudo zypper install libusb-0_1-4 libpcsclite1 pcsc-ccid pcsc-lite

Laden Sie dann die oben genannte Herstellersoftware in Ihr Download-Verzeichnis herunter. Von dort verschieben Sie sie, um sie später leichter wieder auffinden zu können, am besten in das lokale bin-Verzeichnis und entpacken sie dort. Das sieht dann so aus:


Beispiel Cherry[Bearbeiten]

mv ~/Downloads/scmccid_5.0.35_linux.zip ~/bin
cd ~/bin
unzip scmccid_5.0.35_linux.zip
cd ~/bin/scmccid_5.0.35_linux
tar -zxvf scmccid_5.0.35_linux_64bit.tar.gz
cd ~/bin/scmccid_5.0.35_linux/scmccid_5.0.35_linux
su
#>sh install.sh

In der Datei

/usr/local/identiv/ini/scmccid.ini 

sollten mit einem Editor wie kate am Ende die folgenden drei Zeilen ergänzt werden:

CardResetOrder=1
ldd /usr/lib64/readers/scmccid.bundle/Contents/Linux/
LD_LIBRARY_PATH=/usr/local/lib pcscd


Beispiel Cardman[Bearbeiten]

mv ~/Downloads/ifdokccid_linux_v.4.3.2-1-d2622a7fbea0.tar.gz ~/bin
cd ~/bin
tar -zxvf ifdokccid_linux_v.4.3.2-1-d2622a7fbea0.tar.gz
cd ~/bin/ifdokccid_linux_x86_64-v.4.3.2-1-d2622a7fbea0
su
#>./install


Beispiel Reiner SCT (RPM-Paket)[Bearbeiten]

mv /tmp/mozilla_*0/pcsc-cyberjack-3.99.5*.rpm ~/bin
cd ~/bin
su
#>zypper ar ./ lokal
#>zypper in pcsc-cyberjack*.rpm

Ergänzend sollte der pcscd-Daemon zur besseren Kontrolle aktiviert werden mit

sudo systemctl enable pcscd.service


Test der Installation (optional)[Bearbeiten]

wget https://www.seccommerce.biz/seccardadmin/seccardadmin.jnlp
javaws seccardadmin.jnlp



Java von Oracle[Bearbeiten]

Die beA-Software benötigt aus Sicherheitsgründen die originäre Java-Umgebung von Oracle. Die vom beA selbst mitgelieferte Version (im Unterverzeichnis jre) war bei mir allerdings nicht lauffähig. Es empfiehlt sich hier die verlässlichere Installation per RPM. Das entsprechende RPM-Paket kann unter

http://www.java.com/de/download/linux_manual.jsp?locale=de

heruntergeladen werden. Ab der Version Leap 42.1 muss hier zwingend das "x64-Paket" gewählt werden. Ich empfehle jedoch, statt dieser aktuellen lieber auf die überholte, aber vom beA verwendete Version zurückzugreifen. Diese findet sich in Oracles Liste archivierter Versionen unter

https://www.oracle.com/java/technologies/javase/javase8-archive-downloads.html

Momentan (Mai 2020) verwendet der beA-Webclient das Java Runtime Environment (JRE) in der Version jre1.8.0_161. Das zugehörige Paket heißt dann "jre-8u161-linux-x64.rpm". Sollten Sie den beA-Webclient bereits installiert haben, gibt

less ~/bin/beA/jre/release | grep "JAVA_VERSION"

Auskunft über die von Ihrem Webclient bevorzugte JRE-Version. Eine ausführliche Beschreibung für die Installation der JRE finden Sie in der Anleitung SDB:Elster. Bitte verschieben Sie das mit Firefox heruntergeladene Paket wie folgt in Ihr bin-Verzeichnis:

mv ~/Downloads/jre* ~/bin/
cd ~/bin
su


Als Superuser fügen Sie dann, falls noch nicht geschehen, Ihr bin-Verzeichnis, in dem Sie sich gerade befinden, den autorisierten Softwarequellen hinzu:

zypper ar ./ lokal


Hinweis
Anschließend können Sie, auch wenn es nicht notwendig ist, weil mehrere JRE nebeneinander betrieben werden können, ebenfalls als Superuser, das alte JRE-RPM, sofern vorhanden, deinstallieren:
altesjre=$(rpm -qa | grep jre) && rpm -e $altesjre

So suchen Sie das neuste JRE-Paket aus dem bin-Verzeichnis heraus und installieren Sie es:

neuesjre=$(ls -rt1 jre-* | tail -1) && rpm -ivh --nodeps $neuesjre

Zum Schluss wird, weiterhin als Superuser, die neue Java-Umgebung dem System als Alternative bekanntgemacht:

jre=$(rpm -ql $(rpm -qa | grep jre | head -1) | grep \/README | sed "s/\/README//")

update-alternatives --install /usr/bin/java java $jre/bin/java 1
update-alternatives --install /usr/bin/jcontrol jcontrol $jre/bin/jcontrol 1
update-alternatives --install /usr/bin/javaws javaws $jre/bin/javaws 1


Hinweis
Sie können die neue Java-Umgebung auch dem System als Standard vorschlagen, was allerdings bei älteren Versionen nur bedingt empfehlenswert ist:
update-alternatives --set java $jre/bin/java
update-alternatives --set jcontrol $jre/bin/jcontrol
update-alternatives --set javaws $jre/bin/javaws

Diese Einstellungen können Sie für jedes der Programme jederzeit mit der Option --config wieder ändern, z.B.

update-alternatives --config java


Hinweis
Gelegentlich lassen sich Java-Anwendungen nach mehrmaligem Herumprobieren nicht mehr öffnen. Löschen Sie dann im Verzeichnis /root die versteckten Dateien
.oracle_jre_usage
.java


beA-Software[Bearbeiten]

Richten Sie, wieder als einfacher User, zur besseren Übersicht für beA ein eigenes Unterverzeichnis im bin-Ordner ein, in das Sie wechseln:

mkdir ~/bin/beA
cd ~/bin/beA

Laden Sie dort mit

wget https://installer.bea-brak.de/cs/installation/1/beAClientSecurity-Installation.tar.gz

die beA-Software herunter, und entpacken Sie sie an Ort und Stelle mit dem Befehl

tar -zxvf ~/bin/beAClientSecurity-Installation.tar.gz


Nachdem die Atos Information Technology GmbH mit der Ausgabe eines Wurzelzertifikats im Dezember 2017 gegen alle Regeln der Verschlüsselung verstoßen hatte, Die Java-Anwendung kommuniziert mit dem Browswer über per verschlüsselter Kommunikation. Dafür erstellt die Java-Anwendung einmmalig ein für jeden Nutzer individuell erstelltes Zertifikat. Dieses wird bei der Linux-Anwendung mit dem ersten Start im Hintergrund erzeugt. Für die Generierung des Schlüsselpaares benötigt die Java-Anwendung jedoch statt des von OpenSuse vorinstallierten Pakets kdesu das nicht mehr gepflegte, vormalige kdesudo. Dies kann heruntergeladen werden unter:

https://software.opensuse.org/package/kdesudo?search_term=kdesudo

Momentan wird kein spezifisches RPM-Paket in offiziellen Quellen angeboten, nachfolgendes Repository von der Linköping University in Schweden muss deshalb ergänzt werden:

# zypper addrepo 'https://ftp.lysator.liu.se/pub/opensuse/distribution/leap/15.3/repo/oss/' kdesu

Nun kann kdesu installiert werden.

# zypper install kdesu-devel

Ergänzend müssen in der Datei /etc/sudoers die Variablen "DISPLAY" und "XAUTHORITY" hinterlegt werden. Dies erfolgt, indem beide in der folgenden Zeile hinter den anderen Eintragungen und vor dem Anführungszeichen eingesetzt werden:

 Defaults env_keep = "... DISPLAY XAUTHORITY"


Anschließend wird nun die beA-Software als Superuser installiert

su
# sh beAClientSecurity-Installation.sh


"beA läuft nicht" - Warnmeldung
"beA läuft"-Icon in der Konsole
selbst erstellter Desktop-Icon

Anschließend kann man einen Desktop-Icon im Verzeichnis Desktop mit folgendem Inhalt anlegen. Dabei wird per Eintrag in 'Exec' sowohl der Firefox-Browser gleich mit der richtigen Anmeldeseite geöffnet, als auch gleichzeitig (&-Verknüpfung, wenn möglich, bitte ohne Umbruch anschließen) als Superuser der Web-Client im Hintergrund gestartet:

[Desktop Entry]
Comment[de_DE]=Dieser Icon startet den beA-Webclient im Root-Modus
Comment=This icon launches the beA-webclient-application as root
Exec=/usr/local/beAClientSecurity/beAClientSecurity & firefox -new window "https://www.bea-brak.de/bea/"
GenericName[de_DE]=Start des beA-Webclients
GenericName=Start des beA-Webclients
Icon=/usr/local/beAClientSecurity/.install4j/beAClientSecurity.png
MimeType=
Name[de_DE]=beA
Name=beA
Path=/usr/local/beAClientSecurity/
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DBUS-ServiceName=
X-DBUS-StartupType=
X-KDE-SubstituteUID=true
X-KDE-Username=root
Hinweis
Hinweis: Der WebClient startet nicht ordnungsgemäß in der Konsole, solange die Karte noch im Lesegerät steckt!

Beim ersten Start der Anwendung muss das selbst erstellte Zertifikat zunächst noch im Browser hinterlegt werden. Dies erfolgt einmalig durch Drücken des beA-Icons in der Konsole mit der rechten Maustaste und die Auswahl "Zertifikat installieren" im Menü. Beim nächsten Start des Browsers wird hernach automatisch auf den Zertifikatschlüssel zugegriffen.

Hinweis
Hinweis: Sollte Ihr Aufruf von firefox als Superuser in ihrer gewohnten Instanz als einfacher User vom System als unzulässig blockiert werden, prüfen Sie nochmals, ob sie /etc/sudoers bereits angepasst haben (s.o.). Hilfsweise können Sie das Problem mit folgenden Befehlen umgehen:
> sudo -i
> su
# export DISPLAY=:0.0


Erstregistrierung[Bearbeiten]

Führen Sie die beA-Karte in das Lesegerät ein. Unter

klicken Sie nun "Registrierung mit eigenem Postfach" an. Es erscheint die folgende Einstiegsseite:
Bea registrierung.png

Hier folgen Sie den weiteren Angaben.


Troubleshooting[Bearbeiten]

Es konnte keine Karte gefunden werden[Bearbeiten]

Bitte installieren Sie immer die aktuelle Software-Version Ihres Kartenlesegeräts.

Hinweis "Für den Zugriff ... ist eine lokale Softwarekomponente, die beA Client-Security, erforderlich ..."[Bearbeiten]

Bitte achten Sie darauf, den Browser ebenso wie die Java-Anwendung "beA Client-Security" immer als Superuser zu starten. Anderenfalls ist eine Kommunikation zwischen beiden nicht möglich. Möglicherweise müssen dafür zunächst alle offenen Browserfenster des bisherigen Users geschlossen werden, bevor Firefox den Browser tatsächlich neu als einen eigenen Prozess des Superusers startet.

Das Java-Programm startet, aber der beA-Icon erscheint anschließend nicht in der Konsole[Bearbeiten]

Achten Sie beim Starten der Anwendung darauf, dass die beA-Karte noch nicht eingesteckt ist. Anderenfalls wartet die Java-Anwendung von Atos solange, bis Sie die Karte herausgezogen haben. Erst nach dem Start der Anwendung sollten Sie sie dann wieder einsetzen, um sie im folgenden Popup-Fenster als Sicherheitsmedium auswählen zu können.

Sollte dies weiterhin nicht funktionieren, können Sie die Sicherheitseinstellungen der JRE ändern, indem Sie als Superuser

# /usr/java/jre1.8.0_161/bin/ControlPanel

aufrufen und unter dem Reiter "Sicherheit" die Adresse "https://www.bea-brak.de" in die Ausnahmeliste der Adressen eintragen, für welche die Standardsicherheitseinstellungen nicht gelten sollen.

Die Java-Anwendung startet, aber die Passwortabfrage folgt nicht nach[Bearbeiten]

Es öffnet sich zur Auswahl des Sicherheitstokens ein neues Fenster. Dieses ist oft durch die Hauptbrowserseite verdeckt und muss erst "freigelegt" werden, um dort die Auswahl "Kartenlesegerät" anklicken zu können. Sehen Sie bitte nach, ob weitere Fenster geöffnet sind, in denen Sie die Auswahl vornehmen können.

Hinweis: "Der Server ist nicht erreichbar"[Bearbeiten]

Möglicherweise haben Sie die Java-Anwendung wie vorgeschlagen erneut gestartet, so dass dessen Prozess-ID nun nicht mehr zum vorher geöffneten Browserfenster passt. Schließen Sie die Java-Anwendung durch rechten Mausklick auf dem beA-Icon in der Konsole und starten Sie dann Browser und Applet noch einmal komplett neu. Ignorieren Sie ggf. die Aufforderung zum Beenden der bisherigen beA-Java-Anwendung, indem Sie das Aufforderungsfenster einfach schließen.


Kartenverwaltung[Bearbeiten]

beA-Standardkarte[Bearbeiten]

Die Kartenverwaltung der Bundesnotarkammer arbeitet mit einer JNLP-Anwendung, die von den meisten Browsern aufgrund der zunehmenden Sicherheitsprobleme mit NPAPI-Plug-ins seit 2017 nicht mehr unterstützt wird. Um sie außerhalb des Browsers in einer eigenen Anwendung zu öffnen, deinstallieren Sie bitte die störende OpenSource-Anwendung icedtea-web mit

> sudo zypper rm icedtea-web

und legen Sie auf das von Oracle im Java-Paket bereitgestellte javaws einen symbolischen Link:

> sudo ln -s /usr/java/latest/bin/javaws /usr/bin/javaws

Nun lässt sich die beA-Kartenverwaltung öffnen - unbedingt als Superuser, unter dem auch das beA-Postfach läuft:

# javaws https://bea.bnotk.de/sak/cardtool.jnlp


Karte mit Signaturzertifikat[Bearbeiten]

Wenn Sie zusätzlich ein Signaturzertifikat für Ihre beA-Karte bestellt haben, können Sie den für die Installation erforderlichen Transportcontainer nun ebenfalls mit javaws unter

https://bea.bnotk.de/bestellung/index.html#/certificates

unter den Reitern Mein Konto > Meine Zertifikate herunterladen und diesen anschließend als Superuser in der Kartenverwaltung

# javaws https://bea.bnotk.de/sak/cardtool.jnlp

einsetzen. Bitte beachten Sie, dass Sie dafür die untere Auswahl der Karteninhalte wählen:

Aktivierung in der Signaturverwaltung



Externe Links[Bearbeiten]